acura forums   acura forums


Go Back   Acura Forum > Acura Forum (Acura Cars) > Acura TL and TLX Forum

Acura Forum: 1999 TL battery draining
Reply
 
Thread Tools Display Modes
  #1  
Old 09-01-2011, 07:57 AM
jinsunnyvale jinsunnyvale is offline
Junior Member
 
Join Date: Sep 2011
Posts: 1
Default 1999 TL battery draining

For some reason, something is draining my TL battery. I have replaced the alternator and battery, and nothing has worked.

The thing I noticed is the AC seemed to be on even when I turned it off.

Could anyone tell me what happened? Anything I can do by myself other than sending the car to the dealers place?

Thank you!!

Jay
Reply With Quote

lose weight
  #2  
Old 03-19-2015, 07:27 PM
mympsick mympsick is offline
Junior Member
 
Join Date: Mar 2015
Posts: 3
Default

/ATTACH]uploadfromtaptalk1426793033187.jpg
My navigational unit is always dark and orange it works but it's just dark, is this common does it need to be replaced
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 12:34 AM.


Advertisements
cars connected social network


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
acuraforum.net recognizes that "Acura", it's logos and various model names and numbers are registered trademarks of the Honda Motor Co. These terms are used for identification purposes only. acuraforum.net is not affiliated in any way with the Honda Motor Co., Honda, Acura or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on AcuraForum.net requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Acura? Check out your options at the links below: